Not able to pair after a firmware update? Read this!

Hi everybody!

We have received some support inquiries regarding the failure to pair after a firmware update. Sometimes this happens and I recommend completing the following steps to resolve the pairing issue:

  1. Unpair then pair via the app:
  • Go into the app.
  • Go to settings.
  • Unpair your goTenna Mesh.
  • Pair the mesh device.

You should be prompted to either complete the update or notified that an update is completed.

  1. If you are not able to pair to the original phone, try pairing on a different phone. Installing the app is free and you can quickly set up.

We have found that paring to a separate iOS device works best. This may be due to how the operating system’s Bluetooth function works. Once paired and updated, try again on the original phone.

  1. Lastly, if you continue to have trouble after these steps, you can try resetting your network settings.

To reset your network settings, please follow the steps below:


  1. Swipe down from the top of the screen to pull down the Notification Shade.
  2. Tap the Settings button.
  3. Swipe up to scroll down on the settings screen.
  4. Tap Backup and reset.
  5. Tap Reset network settings.


  1. Open Settings.
  2. Tap General.
  3. Tap Reset.
  4. Select Reset Network Settings.

If anyone has further questions or requires more assistance, feel free to email me at anytime!


1 Like

still just flashy led on mesh.

Send a note to Nate so he can be of further assistance.


i got the same problem, tried all steps above, nothing worked…

however this guide helps me pair my device Exit from DFU mode


Tried Armin’s approach using the nRF Toolbox. Didn’t work the first time, but I intentionally drained the goTenna Mesh’s battery and gave it another go. And it worked!

For the Android users out there. Would be helpful if you have your Developer Options > Stay Awake function enabled. Just a little peace of mind so Android doesn’t kill the process while in the background when in the screen is off.


Chiming in to say I had the rapid flashing LED problem where the firmware update was incomplete and the gotenna mesh didn’t connect to my phone. Pairing with a different phone fixed the problem! Afterward I re-paired with my phone (iOS). Thank you for the info!