Mesh 5.0 is here!


guess for me its more a question if it will be an on going issue for the next firmware


I have the same issues.



Today finally managed to update all my 4 Mesh AA12341234.

The IOS app Mesh 5.0 or 5.01 on a iPhone 6S Plus, does not offer the update to 1.1.8

The Android app Mesh 5.0 also do not offer the update at Settings>About

But the update worked on my android project fi Motorola X4, with the Mesh 5.01 app.

The moment i paired each of the 4 GTM the update was immediately offered (and i accepted it) and proceeded as follows:

  • After 15 seconds, the “1.1.8 Firmware Update in Progress” appears going from 0 to 100%.

  • This is the slowest stage and took 42 minutes. The GTM leds blinked 3 times, slowly most of the time, but fast, the last minutes.

  • The second update stage from 0 to 100% took only 15 seconds. The GTM leds were fixed white.

  • The third update stage from 0 to 100% took 1 minute. The GTM leds blinked fast, 3 times.

  • The last update stage from 0 to 100% took 45 seconds. The GTM leds blinked fast, 3 times.

  • Some 5 seconds later, the “Firmware Update Complete” message pops up.

After the update both IOS or Android Mesh 5.01 apps work well with all the 4 GTM’s, and at Settings>About show the firmare version to be 1.1.8.



I can confirm as well that I have updated successfully to 1.1.8 a GTN with sn AA12341234 on android oreo with 5.0.1
So the update of the android app fixes this issue. Thanks!


I tried 3 different Android phones; Nexus 6P, Essential Ph-1, Unihertz Jelly-Pro. All on Android 8.1. All 3 said, “This firmware upgrade is not applicable for your unit. Please contact gotenna support for further details.” when paired with my MX173 mesh unit.


Among the goals with 5.0 is to fix the previous firmware update problems with a revised process. I know that at least some of the 5.0 Beta test hardware that was in hand seemed to update to this first street version painlessly. Will know more once I get through the network in the next few days, but this should be worth all the uncertainty and pain its brought for some of us.


OK, those are more than recent enough at the OS, so that’s not the issue. You should drop a note to customer service or directly to @Virginia and they will track down a solution for you.


That’s interesting to see that the 5.01 app is working for some (Android?) folks to update AA12341234 devices.

The IOS version of the 5.01 app will not update the firmware on my two AA12341234 devices. It pairs successfully with them, but does not prompt to update the firmware or offer the manual firmware update button. In essence, IOS 5.01 seems to operate identically to 5.0 for me with regard to AA12341234 devices.


I’ve had two MX units upgrade successfully. I have one MX unit that failed, and four AA12341234 I cant upgrade. I have more MX units to do but this is getting very frustrating. kind of getting pissed.

Update, I was able to get my MX unit working. I had to play around with rebooting the gotenna and phone app to get them to link up and finish the update.


That’s correct. I believe the fix for that on Apple is in. It was waiting internal QA approval and then awaiting approval by Apple. I suspect it’s out the door at goTenna and in Apple’s hands now, so we hope real soon on that.


Did 5 of the AA12341234 this morning, all my units are upgraded now. Using a Google Pixel 2 XL.


Unless currently in use that can’t be foregone, I’d go ahead and try updating the other MX units. This generally goes OK (mine were all fine), although there are exceptions as you’ve found. That way once there is a solution and you contact customer service you’ll know exactly what still stands to be fixed.


Keeping this for future reference. I just reloaded the app after trying everything else I could think of to update my second device.


so taking mikeL advise tried the upgrade, went to 100 then back to 0 and nothing is happening now…



@Idaho_Fluke I know on mine the bar seemed to complete and restart a few time. I actually sort of wish that they had utility you could download for the PC that could the updates instead of doing over the Bluetooth connection.


Yes, the first step is the long one, downloading the firmware to the GTM,

I’d say things stalled. This is after the long first step was done, so this is for the install (second step)? You may want to wait a little longer to see, but my best guess is that it’s stuck there. I’d reboot and try it again. You may want to check which version is active after your reboot as that could fix things and finish the install as you do it.


I noticed that 5.0.2 is now available for iOS. Anyone know whats new with this version? The app store update details don’t mention anything new.


after never changing, a restart / reboot and now it wont pair back to the phone, no light on the GT


5.0.2 will allow you to initiate firmware updates with the AA12341234 goTenna Mesh!