Mesh 5.0 is here!


Sounds like the last one I was working on this evening. Got stuck starting the download, sorted that out, then got stuck installing it, now shows as disconnected but pairing/unpairing isn’t working…

I feel your pain. Will try a few more things then I’ll drop a note to Virginia. Have you tried that option yet?


@MikeL which option are you referring to?


Sending a note to @VirginiagoTenna


Gotcha. I’ll do that.


Have you tried putting the gotenna mesh into relay mode? Then turn it off. Hold the power button down until it starts flashing again and try to pair?


Please pull the update. My success rate with updates is less than half. 2 working, 3 bricked and 1 didn’t update and will not update. The support I get is reinstall the app it should work. Reading through this thread, my experience doesn’t seem unique.


Thanks for posting, we can certainly help you get setup on 5.0. Units aren’t bricking… there is a known behavior discussed here wherein units do not move out of the DFU state. This is not a bricked Mesh. I’ll send you a DM to help.


I’ve had good luck with turning off the gotenna, setting the app to start pairing, and then turning the gotenna back on. it seem to catch the gotenna in the first part of the boot up and finishes the firmware update. I’ve had to play around with turning the gotenna on and off as well as the app. There is a sequence that works after an update fails.


Hello everyone!

Thank you for your great feedback on this thread, it has been so helpful for us as we rollout this update!

You also helped alert us to a critical issue in early production models of Mesh, which used a different mechanism for bluetooth connection. We completed some rapid testing internally, and discovered that the firmware on a number of devices with MX”” or GD”” serial numbers cannot be updated to 5.0.

We’d like to replace ALL affected units completely free of charge, as we want everyone to be able to update, and enjoy 6 hops and Emergency Beacon.

If you received your goTenna Mesh devices prior to December 31st, 2017, please review your serial number within Settings > About > Device Information.

If you:

  1. You do not see a blue update firmware button
  2. Your firmware version reflects 13.48 or earlier
  3. You may also see a notification when you pair which indicates that you device is not eligible to update.

Please contact! We’ll assist with replacements ASAP.

Again, we greatly appreciate your feedback and engagement.

Thank you!


Considering we’re a little over a week in with 5.0, I’d say things could be a lot worse and even the difficult ones s look like they’re mostly headed toward resolution. Yes, there are issues and that’s not surprising considering the GoTenna mesh is designed to work with the products and software of literally dozens of different vendors. For the most part it does work fine, for some others after a little frustration, and for the handful of hard cases, well goTenna has a plan in place.

I’ve done roughly a dozen firmware updates. I have just two that are stuck and fortunately enough spares I can be patient in dealing with them. I think one was my wife’s original (i.e. pre-31 Dec. 2017) and I think the other has 13.48 firmware – solutions seem already identified.

Performance is definitely a great deal better. Went south last night to feed the cat of some friends who host one of our nodes. This was almost always a three hop jump and then not always a sure thing. Last night it went in one hop, 3/4 mile in low density urban terrain, basically up to the rooftop then to my wife’s GTM. The new update also solved all the problems she seemed to have been having with that older pre-Dec 2017 GTM she was using before.


I could’ve sworn there was something here about if the update hangs, that going to relay mode first and then turning the unit off can help. Has anyone tried that with any success?


That is what @wvs is referring to, I believe. It could work, but the trick is the timing as wvs observes. The one is definitely stuck trying to install the firmware. I saw it finish the download. Then rather strangely, instead of going to the firmware install warning, it offered a chance to download the firmware again, Since these sorts of dialogues tend to confuse me, I suspiciously told it no.

Then it was stuck.

I ended up powering it down and walking away. That’s one of my main tech strategies when I get stuck, so I guess I’m a bit of a Luddite, but it ften works for me, A few hours later I tried once more, figuring I’d have to download the firmware again.

Nope, it seemed to be busy installing the firmware finally. Of course, it’s still doing that almost 24 hours later, when I do try to get its attention by poking at it some more.


I’ve already sent my 3 devices, will they ship right after you receive the units, or after one fills out this form? I realize I probably don’t have to fill it out, but the wording on the form seems to suggest that the new units will be sent after filling the form and getting the email, not after you receiving the units. It’s not really a big problem for me anyway, but it might for other people who needed to use their GoTennas soon.

Also, if someone like me needed to fill out the form, they probably couldn’t fill out the serial number field (which is “required”), since I don’t think it’s possible to get it from the unrecoverable Mesh units?


Just successfully updated my goTenna. Here’s the log I wrote while the update was occurring:

Update log of goTenna Mesh mx173xxxxx from 0.13.48 to 1.1.8 using app 5.02 on iPhone SE running iOS 11.4.1. This goTenna unit was received March, 2018 as a replacement.

Initial connection in app prompts for available update. Blue button present in About window.

Attempt 1:
Starting update at 6:28 PM
Update started, red LEDs on (unit was charging), white LEDs triple fast flashing at half brightness. Seemingly normal update behavior.
6:55 PM - Update stopped at 97%, white LEDs stopped flashing.
Notification that firmware update failed and to reboot and try again.
Restarted Mesh and app. Had to manually re-pair as app couldn’t connect. Have seen this behavior under normal conditions with new app and older firmware.
End of Attempt 1.

Attempt 2:
Started update at 6:59 PM
Transfer finished at 7:27 PM. Installation started. White LEDs went solid on, followed by rapid flashing, a reboot pulse, and more flashing.
Update completed at 7:30 PM.
App shows firmware 1.1.8 on device.


Also, as a note, for those that have issues reconnecting to your Mesh unit, I’ve noticed that my unit on the older firmware would have trouble connecting to the app. It appears to be an issue with the app itself, as the iPhone 7 I initially tested with got quite warm when the goTenna disconnected. Each time I’d try to force the app closed and re-open it, the goTenna’s LEDs would go dark like it was going to pair, and then fall back to the disconnected pulse. I had to go into the Settings, un-pair the goTenna, and then re-pair it. It always reconnected after doing this.

When the goTenna is disconnected, the LEDs pulse brightly at a rate of 9 flashes every 10 seconds. While installing firmware, they flash at roughly 6 flashes per second, half-brightness. When downloading firmware, they triple flash rapidly at half-brightness, one triplet per second.


I had no problems updating my four MX Gotennas. And one of my AA Gotennas updated without a hitch after the app update. But the other AA Gotenna failed. Yet, that Gotenna indicates that it is running 1.1.8 and at least SEEMS to be okay. It also won’t let me repeat the update just to be sure. Should I place complete trust in this unit before I can do a successful update?


Disappointed that it’s still complicated exchanging GIDs even though this would have been trivial to code.

  1. No qrcode displayed.
  2. On iOS not even cut and paste works.

Have to use the “shout” fallback.


Does SMS text support QR code imaging?

Agree that for swapping GUID info some improved solution is needed.


Hi MikeL,
Using SMS option 2 (gotenna supporting cut and paste of the GID) would be sufficient.

I added a photo to the main discussion to show what I mean. On most android/iOS phones it’s enough to point the camera at the image.


Ah, OK, I see what you mean.

True, if you have cell service on the phone you’re using, that could be useful. As a non-cellphone user (mine is just a device without cell service) I can see that would work so a nice option to have. However, it wouldn’t work for me.

Maybe the exchange of GUIDs via Shout could be via a designated button somewhere. That would be universal to everyone using a GTM. The process is obvious once you’ve waded into the mesh and found out more, but is not really all that clear to those just starting out with a Contacts list to fill.