iOS GPS accuracy


I allowed iOS access to everything it asked during setup. This problem exists even with the app running if the foreground.


This issue has existed across multiple versions of the gotenna app. I have also experienced it on multiple different models of iPhone running different versions of iOS.


Could it be related to these?

There is definitely a systemic problem with the recent iOS devices and GPS accuracy.

I can personally confirm that acquiring a 3-D GPS fix takes about 7 minutes longer on my iPhone 6 than it does on my Android device sitting right next to it.

Neither of them are within range of any data network at the time. On Android, it takes roughly 7-8 seconds, while on my iPhone it takes 7-8 minutes. It’s horribly slow, and I am running iOS 12b8 on my iPhone as I type this. It hasn’t helped.

Have you tried the ‘Reset All Settings’ option suggested in the last link above? There are claims that it works, but slowly fails over time again and has to be re-run periodically.

The other thing I’ve found that people are reporting helps (outside of the goTenna Community, but all using apps that require highly-accurate GPS confidence) is to disable LTE on your phone. This is hidden under: Settings → Cellular → Cellular Data Options → Enable LTE, and toggle that last setting to Off.


I’ve tried all those things. I do not believe those issues are related to the problems I am having. None of my many other GPS apps have exhibited any problems at all. Both in or out of airplane mode, with our without LTE turned on. The problem only exists within the gotenna iOS app.

On a couple iPhones I tried a full erase and started fresh. Didn’t even restore from backup so no corrupted data. Problem in the gotenna app remains.


I have an iphone 8 and a 6 plus both with ios12b8. I have some type flaws regarding the location on the iPhone 8 but I do not notice it on the iPhone 6 being this much more precise


Hello Mike.

I’m writing on behalf of the goTenna iOS team and want to assure you that we will spend time and effort to track this down and release an update once we find and fix the issue.




iOS 12b10 had made quite a lot of improvements over b8, including shedding that horrible battery drain. Location aquisition appears to be a lot quicker too.


That’s good news unfortunately this glitch has existed in the gotenna app for a year or more and on everything from iOS 10 to the latest iOS 12 beta. Which I’m running.


I had this location issues just the other day. Only seems to happen in the goTenna app. My other apps, google maps, me.maps, and Earthmate (Garmin inReach) all have my correct location.


Yes, the problem persists and little is being done to address the issue.


Hey so I recently received my first two mesh units and this problem definitely still exists. Wish I did a bit more in depth research into these things before I bought them. Not exactly satisfied with the performance so far. Was going back and forth with customer service rep on the issue and she was giving me different suggestions as to what I can try to do to correct the problem, hard reset of app etc. None of which worked to correct the problem. Perhaps she should just have told me that there is no solution to the problem versus wasting both of ours time.
Not sure at this point if I just want to return these and get a refund. Loved the idea of them just too bad there are so many limitations and that if you want to slightly improve them you have to pay more money for an ‘upgraded’ service. Just wish the app would work as advertised.


@ShootAnyAngle - thank you for starting this thread!

I just received my GTMs just under two weeks ago on 10/31/2018, and ran my first field test a few days ago at an amusement park.


  • Gotenna app version 5.3.1, build # 125 on both phones

  • iPhone 6 and 6+ on iOS 12.1
    – My GTM and 6+ were in my ski jacket’s chest pocket
    – I left the GT app & Bluetooth running in the background all day on my 6+
    – My wife’s GTM and 6 were in her leather purse
    – I don’t know if my wife opened / closed the app as needed, but likely so; Bluetooth & GTM were both left on all day

  • Both devices have each other manually entered in their other’s address books and are set to auto-accept location requests

  • GTMs and Bluetooth were left ON all day at the amusement park

Here are my observations:

  1. I requested my wife’s location in a 1-1 chat approximately 5-10 times between 7PM and 8PM. I kept getting no response, even when my request showed a green check mark that the request was received. We were together most of that time, and within 1000 feet of each other at the most.

When we returned home later that evening, I received a ton of location responses. It’s like they were queued up and reported all at once. I am guessing that her GTM held onto my location responses and replied hours later.

I noticed that all location responses had the “current” time stamp of 10:32PM, not the time stamp of the actual request or response throughout the day, which I thought odd and totally not useful. The location responses should be timestamped with the time of the location response. Also, all the locations reported were home, not at various places at the amusement park.

My GTM had approximately 65% battery left when I checked after returning home at 9:30PM. We left the house at 9AM.

  1. After returning home that evening, I did a location request and my wife’s iPhone 6 reported itself back at the amusement park, approximately 50 miles away. I requested location again a minute or two later, and it reported location correctly. Maybe the GTM app needs to either wait a minute before replying with a location or just request a location update from iOS when it receives a location request from another GTM unit. In my opinion, drain the battery! Incorrect information is WORSE than useless - it can be deceiving at best.

  2. While my wife was driving us down to the amusement park, I was playing with the GTMs in the car, requesting locations. Her iPhone 6 was not reporting the correct location on occasion. As suggested by GT in this thread (which I read prior to our excursion), restarting the app fixed the location. The only problem here is that, if I request her location, she does not know her location is being requested and to proactively restart the app to force a location update.


  • Copy and paste the topographical map’s GPS code / settings to the flat maps!

I am willing to actively work with someone at GT to fix this. Please feel free to reach out to me.


Given it’s a known problem and there is a known solution, until a firmware fix solves it, suggest enabling topo maps.


Hi Everyone–appreciate hearing from so many people about this. We have an update to address this planned for the next app release, and we will keep everyone here posted. This should increase location accuracy but of course there will be an impact to battery life, particularly when sharing location in the background. Thanks again for all the feedback!

iOS app v.5.3.2 is here!


Thank you very much for your quick response and upcoming solution! Do you have a time frame (weeks or months) for the next iOS app update?

My offer to assist you is always on the table, especially if this app update is off the mark. I eagerly look forward to the update!

BTW, I was in the crowd at the Hardwired Meetup at kbs+ in NYC featuring Daniella Perdomo on 11/11/2013. I originally attended to learn about the August Smart Lock, and became intrigued by Gotenna. Glad to see Gotenna growing!


Interesting how the only solution is to activate topo maps, which conveniently incurres a subscription fee.

Funny how so many other software & firmware bugs for gotenna get patched relatively quick and yet this problem (which can only be fixed by paying gotenna more money!) has existed since the early release of Gotenna Mesh.

We have seen little progress or concern to remedy it in anything close to a timely manner, even with many customers reporting this problem.

I guess any bug in the app that forces its users to pay gotenna more money isn’t a high priority to fix if it helps them rake in a little extra cash from their customers that already dropped nearly $200 for a pair of these things.

I own over a dozen of these devices and was planning to get several local towns emergency services & search and rescue involved with deploying Gotenna Mesh. But after waiting more then a year for this bug to be fixed I think I’m going to call this experiment a failure and just sell them all off and stick with my reliable ham radio APRS which ACTUALLY transmits my REAL and ACCURATE position instead of USELESS and OUTDATED coordinates that is DANGEROUS when used for search and rescue.

If this doesn’t get fixed quick I think I will be going out of my way to advise friends, family, and strangers to avoid Gotenna Mesh like the plague.

It’s a shame, I really liked the idea of Gotenna Mesh.

James Hannibal - KH2SR


Or it might just be a more difficult fix than you suppose?

At $10/year (currently, on a list price of $29.95) I think this line of reasoning is a bit overdrawn. Frankly, it’s a trickle of revenue that helps contribute to funding updates. Or you’d rather they just ignore updating anything? Thank your lucky stars you’re not involved with Adobe, MS and some of the other which expect you to pony up big bucks every month.

The topo maps are clearly a temp fix, but it is available, so no need to to insist it’s dangerous as a whole. Personally, if accurate positioning isn’t already available to EMS services, then why insist there’s no fix when one is readily available at very low cost (> 3 cents/day, but also covers other value-added services, too) right there on the device? If it was me, I’d want the Topo maps on all the time anyway. Unless you live somewhere flat like here, then what’s uphill or down has some relevance to most EMS, fire, etc. If it comes down to money, as you want to present it, then the argument is over pocket change and it is only tangentially about technical failure.


It’s not a “temp fix” when it goes on this long.

It’s not up to you to decide for other people if they should pay extra for something just to get it to work the way it was supposed to in the first place.

I’ve read a lot of what you post on here and you seem to defend gotenna at every turn no matter what. Brainwashed Hardcore fanboy or employee?


If you’re not a programmer, then you’re not really in a position to know how difficult this is. It’s even possible it got fixed then Apple updated things and broke it again. I don’t know. But I do know that when the sky starts falling over a few pennies, even when there’s a workaround, then it’s not the technical problem that’s the real issue. “People are funny about money…” is a truism that has little to do with technical issues. You’re entitled to see things your way. Others may pragmatically disagree, that is all.


Guys, the answer is very simple: We just launched multiple products for goTenna Pro and with a tiny engineering team all of our resources have been there for most of the past year. We were able to sneak in the 5.0 app release but only barely. We just haven’t gotten to it because we literally don’t have enough people to throw at the problem, we apologize!

As annoying as the problem is to you it is a “super-user” issue that actually affects few people since most users of Mesh don’t even use this feature. Thanks for understanding. However, as noted earlier in this thread @MikeR is looking into how/when we can do an interim release to address this. We appreciate your patience and support.