Exit from DFU mode

I have a bricked GM unit, tried this method and am stuck here:

  • Uploaded the first .zip file, and now the device isn’t showing up in nRF. Turning it off/on, the LED flashes only once and doesn’t connect to either the GoTenna App or nRF.

Any advice? I do have an android device and windows PC available, but don’t have a USB-C to USB Mini cable.

I just found this thread this evening. I don’t have an Android device lying around, so I gave it a shot on my iPhone 12 Pro Max with nRF Connect 2.4.7 for iOS.

I downloaded an APK of goTenna with firmware version 1.1.12, extracted the nrf52_*.zip files, and uploaded them (phase 1, phase 2 part 1, and phase 2 part 2) to nRF Connect via iMazing on my MacBook Air.

nRF was able to communicate with the goTenna Mesh in DFU mode, saw the nrf52_*.zip files, and was able to upload them to the goTenna Mesh.

After phase 1 was uploaded, nRF was able to quickly reconnect to the goTenna Mesh (still in DFU mode).

After phase 2 part 1 was uploaded, nRF had to refresh in the Scanner view, but was able to reconnect to the goTenna Mesh (still in DFU mode).

After phase 2 part 2 was uploaded, the goTenna Mesh rebooted and worked.

Thank you so much for posting this guide. Even though goTenna Company was willing to replace the unit, I figured I would give this a try first, which saved them money and me time :slight_smile:

Under which directory is the .zip file there are a bunch of directories
I found some in /res/raw but not sure if those are correct. also when I try to upload those zip file it says “DFU characteristic not found” ??