goTenna Mesh community

Can I repair this device?

Hello everybody!

I have two original Kickstarter mesh devices which experienced the infamous DFU mode issue after a failed firmware update. I was able to get one of them up and running again using the nRF Toolkit method, but doing the same thing for the second device did not work. It didn’t reboot itself after uploading all three pieces of firmware, so I rebooted it and tried again. After sending the first piece of firmware again, the device no longer shows up in the device list in nRF Toolkit.

Using the serial console, no errors are being reported, other than if I run usbble 1, then ble_mac, it prints the following:

[3042622-2797, USB, ERROR] queue 3: status=1921

ble_state prints the following:

[3138357-3042, USB, INFO] BLE_STATE: bluetooth_status_flag=disabled
[3138357-000, USB, INFO] BLE_STATE: forced_off=no
[3138357-000, USB, INFO] BLE_STATE: nrf52_connect_status=not_started
[3138357-000, USB, INFO] BLE_STATE: ble_enable_state=UNKNOWN
[3138357-000, USB, INFO] BLE_STATE: last_bcts_sent_at=0
[3138357-000, USB, INFO] BLE_STATE: last_msg_sent_at=0
[3138357-000, USB, INFO] BLE_STATE: last_msg_recvd_at=0
[3138357-000, USB, INFO] UUID type 0x00, srv handle 0x0000, conn handle 0x0000
[3138357-000, USB, INFO] BCTS char handles: value=0x0000, user_desc=0x0000, cccd=0x0000, sccd=0x0000
[3138357-000, USB, INFO] VATS char handles: value=0x0000, user_desc=0x0000, cccd=0x0000, sccd=0x0000
[3138357-000, USB, INFO] VATC char handles: value=0x0000, user_desc=0x0000, cccd=0x0000, sccd=0x0000
[3138357-000, USB, INFO] first handle=0x0000, last handle=0x0000
[3138357-000, USB, INFO] Current mtu 0, payload len 0, bcts enabled0

I’m definitely no professional with this but it appears to me that it may no longer be broadcasting anything wirelessly anymore but no errors are being reported other than the error message when I try to view the MAC address. I’ve tried rstdata and other commands that look like they may help but nothing has helped so far. Is there anything else I can do myself to repair this device? I’d love to be able to just flash it myself over USB but based on what I’ve read that doesn’t appear to be an option for some reason.

I have contacted support already and they have offered to replace the device, but for sentimental reasons (these are original black Kickstarter devices, I’d rather not replace them) I’d really like to just fix the one I have. It’s probably a stupid reason, I know. :sweat_smile:

Take the black bands off to keep and get the free replacements.

Thanks for the response! I have considered that, but ultimately I really would like to know if there is anything I can do here without having to replace anything.

Have you tried all these methods: https://support.gotennamesh.com/hc/en-us/articles/360022845872-Firmware-Update?mobile_site=true

I have, unfortunately it didn’t make a difference.

Hi there,

Please don’t hesitate to reach out to support@gotenna.com in case you change your mind and decide to swap your units.

Thanks,
Naz

1 Like