How to make a unit stay on?!


#41

I suspect this will become known as the Brute Force Method. :construction_worker_man::construction_worker_woman:


#42

Sorry, this is the part that didn’t go seamless for me. It’s probably because I’m running at full 1 Watt, but as soon as the battery-less Gotenna tries to transmit, it power cycles and resets. Happens consistently with an assortment of power supplies and cables too. Stops happening when I reconnect the battery.
I think an extra capacitor may be required to do this trick at full power. Any experience with this?


#43

This is unfortunately correct and confirmed. Thanks @armin and apologies to everyone, I should have tested under more conditions before posting.
I have edited my original message to include a warning.


#44

Interesting idea. I have to guess that adding a capacitor to temporarily store power from the USB external power connection (might need to be a “super-cap”) could work, as long as transmits are not constant once the thing gets going. Heck, it might even work if they are.

Might be worth some experimentation though.


#45

So what happens if you leave the GoTenna battery connected, and force the power switch? Charging up from dead, it might take longer to reach turn-on voltage, and/or the slow ramp-up might not play nicely with the internal power-on-reset circuitry, but worth testing. I will try to run one of mine down to 0 then charge/power it up to see (no intention to hammer any apart).

One thought on the firmware side would be to have a GTM unit (either by setting, or perhaps by default) automatically go into Relay mode (LEDs and BLE off) 1-2 minutes after power-on if still unpaired. At worst this might require the user to power the GTM off/on in order to pair if it wasn’t done originally or lost the link with the phone… just a thought.

Alternately, am I correct in assuming that any GTM unit can be used as a relay without being set to relay mode, the only downside being the greater power consumption due to BLE and the flashing LED? If that’s the case, how big a penalty is it?


#46

OK, for what it’s worth, I let one of my GTMs run down to the point where it did not respond to its power switch, then left it overnight. Held the switch down and connected USB power; it came up normally with the red LED, also flashing white, and reconnected to my cellphone almost instantly.

So it would appear that a less-than-optimal but no-disassembly way to auto power-up a remote unit would be to mechanically keep the power switch depressed, and apply power when available.

A suggestion for a GoTenna firmware mod would be that if the power switch is depressed for, say, 30 seconds (as opposed to the 1-2 powerup or 4-sec relay mode), then go into relay mode (LED and BLE disabled). Not likely to happen by accident, no interference with normal operation, except that turning off such a relay would require removing the switch clip (anyone care to 3D print such a clip?)


#47

Interesting. It’s clear you tried it with a previously paired GTM. Did it work with a unit in relay mode or are you speculating that it might work with a GTM already in relay mode?

Since you need to keep the power button depressed with this approach and to put a GTM in relay mode you need to push the button down 3 times to stop the flashing LEDs, then 3 more times to put it in relay mode, these procedures may contradict each other.

Just trying to figure this out, while I experiment…


#48

A nice custom 3D printed clip may become needed if this proves out. For now, I grabbed a scrap of piano wire (also known as music or spring wire, 0.045" diameter in this case)) and bent a clip like this,

Here it is installed.

You can pull and release the arm sticking up to give you the pulses of 3 + 3 quick blips of the power button needed to set the GTM to relay mode.

I’m getting various reactions to my clumsy messing with things, The most obvious one is doing the 3+3, then letting the clip hold there after the final blip. The LED stays illuminated briefly, then shuts off. Not sure what mode this means it is in yet, though.


#49

@MikeR I read earlier that a hardware rev/change was in pipeline and would address this. I, as others here have noted, would buy new units to use them for dedicated relays. what is the ETA?


#50

So far, here’s what happened. I made the clip pictured above, but have rebent it several times to get a better grip. Be aware that using just the wire may crease or cut into the rubber dust cover of the power switch.

I tried to put an unpaired GTM in relay mode but could not figure a way to confirm it was doing that with the clip on. I could blip it 3+3, then leave the clip on, and the white LEDs kept flashing, on and on. Then I went to sleep…

This morning, clip was on and no flashing. Dead. I plugged in the USB power. Red charge LEDs came on. I blipped the clip once, making sure I did not hold it long enough like you do when started the GTM normally. The white LEDs started flashing. So no need for pushing the button long enough to power on as is typical.

That said, it was just in pairing mode, at least according to the blinking white LEDs. So I blipped it 3+3 to put it in relay mode. The red LEDs stayed on steady, indicating charging, but the white LEDs went off.

I assume it’s in relay mode - maybe. When I blip the clip once, the white LEDs illuminated briefly once, then went out.

I’m leaving it on charge to replenish things with the clip on. Then I will let it run down all the way again, again with the clip on. Then I will plug in power, etc as above. I suspect it will come up in pairing mode again as it seems to have done here. Maybe I’m missing something though if it shows up in relay mode the next time I test it? Will update when I know more. Curious to hear of other’s results.


#51

Perhaps someone from GoTenna can confirm that

1 - can an unpaired unit which is flashing in pairing mode still relay?
2 - can a previously-paired unit (say, with a random GID) which is flashing because it doesn’t see its paired device, still relay?
3 - if the unit in case (2) receives messages for the offline bluetooth device and buffers them (which I have experienced), what will happen when its buffer memory “fills up”? Will it (a) ignore newest, (b) discard oldest, © discard all, or (d) stop relaying for lack of memory?

If the answers are 1 “Yes”, 2 “Yes”, 3 anything except “d”, then one could ignore the fact that a GTM is flashing and simply power it on and use it as a relay, correct? The only negative would be the extra power drain from the flashing light and BLE. Right?


#52

Let the GTM fully charge with the clip continuing to be on except when I manipulate it. Unplugged the USB cable several hours ago. Decided to check to see the response by blipping the clip once. The white LED comes on steady briefly, then started flashing, I think five times. Then it went out. After a second or two, the GTM started flashing like it wished it was paired. I did the 3+3 blip sequence and it seemed to go into relay mode the first time I tried it, so it wasn’t in relay mode prior to this. Or it was and slipped back to pairing mode. Or something else.

Because now when I’ve tried doing the single blip inquiry and leaving the clip on otherwise, I instead get the steady on, then 5 flashes despite trying to initiate the 3+3 blips sequence by doing the first 3 blips. This now just turns to white steady briefly, then it does the continuous “pairing flash” thing. I suspect I was mistaken in recalling that I managed to get it into relay mode and it seems like it’s not possible to incorporate the 3+3 signaling to initiate relay mode if the key is at the same time otherwise pressed continuously.


#53

@Redline, some answers…

  1. yes
  2. yes
  3. a

correction: the device will ignore new messages coming in when memory is full.

The device should always be able to relay messages when powered on regardless of what mode it is in. Relay mode simply helps conserve power because no GID is associated with it and the the device therefore doesn’t have to process 1:1 and group messages that it might receive.

@mficiencies we are testing some pre-production units but there’s no timeline on availability yet…we will certainly keep everyone posted.


#54

MikeR, thanks. So quick-and-dirty solar-powered relay mode would be to physically jam the power button on, then the GTM should turn on whenever power is applied, at the expense of some extra flashing and a bit of power consumption.

I don’t imagine that processing messages would increase consumption much, unless you are doing some fairly sophisticated CPU power management tricks.

FWIW, in a previous life I designed and compiled/submitted FCC and IC reports for licensed narrowband as well as unlicensed Part 15 equipment, including 900 MHz, so I understand about keeping the factory antenna.

So what a dedicated relay unit minimally needs would be a right-angle gasketed micro-USB power plug with a power-button-squeezing clip assembly, maybe printed into a bracket suitable for mast mounting, and 20-30 feet (10 m) of cable. The rubber strap slot could be used to lock the unit into the mount, and assuming the device is otherwise sufficiently raintight to survive outdoors, that’s a wrap!
Hmmmm.


#55

I think you’d want to box the unit unless you live in a mild, dry climate. It’s water resistant, but not waterproof. I use this inexpensive (~$10) unit to house my home relay node. I file a notch in the lower lip of the box to allow the USB power cord to enter, sealing it with a dab of silicone RTV sealant to form a tiny gasket.

Moving on, I redesigned the “Powerclip” somewhat. Using “2 wires” by bending the wire in half to begin with and using 0.039" spring wire makes it easier to use and less damaging to the rubber button seal.

It’s also more secure when in place, in part because one arm goes under the strap as you can see here.

I suspect we’ll attempt to implement this in several nodes if the weather warmup slated for Sunday makes things safe enough to start the reboot process for the down UMESH nodes.


#56

I can’t seem to make this work. I’ve jammed the power button down on initial startup of an unpaired GTM and get a flashing white light like it is trying to pair. After letting it die and then plugging it in to power all I get is a red charging light. The button is still jammed down. It doesn’t respond to shouts with a momentary white light like it would if it was in relay mode; it is just off and charging. I un-jammed the button and confirmed this. It would only power on if I did the usual start up long-press.

Any ideas?


#57

You should be able to get it started after plugging in the power by briefly punching the power button. It should respond with a long white LED illumination then 5 brief flashes, then it goes to just charging again (red LEDs only) briefly before started to flash the white LEDs repeatedly and continuously.

It should be able to relay then, although it’s not technically in what is called the relay mode.


#58

Dang. I thought this was going to be the answer to a simple solar relay node. Thanks for the reply


#59

Well, it should be. A piece of wire, some bending and fitting, and it is supposed to be in relay mode and stay in it whether powered 24/7 or not.

I still want to do some testing for comparison purposes vs an actual relay mode node once the weather gets better. Right now, just keeping nodes up is the priority.

Is yours refusing to initiate as described?


#60

Mine seems to just be powered off and charging with only the red light illuminated. I’ve just taped the switch down so I can’t quickly tap it like you. After removing the tape though it takes the usual long press to get it started up again. This GTM is updated to 1.1.8 if that helps.

This would be exciting if it did come back on into pairing mode (relay mode would be better) I have had good success using nodes that are in pairing mode but not paired to anything as relays.

What am I missing?