goTenna Mesh community

GoTenna won’t wake up or charge

One (and only one) of my four GTs isn’t happy after sitting unused for a while. May have been in relay mode when last used; thought it was off. Now nothing happens when connected to a charger for days… saw a very faint red glow while plugged in and various button pushes, but still pretty much dead. Ideas on how to resurrect?

Due to some inadvertent connecting to a problematic solar charge controller, I did manage to blow the charging circuit on one of the devices here. Yours behavior sound much like the aftermath of that. Any changce that could’ve happened to yours?

Thanks, but none at all. All four have only ever been plugged into standard USB chargers (and usually the same 6-port device).

OK, ruling that out as a cause, but it sounds like the same issue, a blwon charging circuit. I assume you’ve tried a different charger with the same results? Just to rule out the possibility that it’s the charger that has failed.

Charger is fine - using it now with other devices and tried a couple of other chargers as well.

1 Like

Sometimes things just fail. Besides my obvious mistake that resulted in my charge circuit failure. I think I possibly recall another one or two similar failures. It’s a pretty rare failure. If they still might be under warranty, that would be a good way to deal with this. I’d check in with Support/CS just to see what they say even if not.