Blockchain & goTenna Mesh


#44

you can read up on pip, but the way it works is pretty simple:

pip install goTenna-0.12.5-py2-none-any.whl

Your goTenna should just be plugged in to the USB port and unpaired to a phone. If it doesn’t connect right away when txtenna.py starts up, then you might need to power cycle it (it fell into a sleep mode).

I should check in my example index.js . It took me awhile too. My file is configured txtenna-server to use my local bitcoind setup for testnet.

The keys/index.js was tricky for sure, the key part is pushtxWrappers section, mine looks like:

push txWrappers: [
{
type: ‘bitcoind’,
// Network supported by the wrapper
// Bitcoin mainnet = ‘m’
// Bitcoin testnet = ‘t’
network: ‘t’,
// Name identifying the wrapper
name:‘goTenna bitcoind testnet’,
// Configuration of the wrapper
options: {
// RPC API configuration
rpc: {
// Login for the RPC API
user: ‘cookie’,
// Password for the RPC API
pass: ‘<your RPC password here>’,
// IP address of the bitcoin node
host: ‘127.0.0.1’,
// TCP port of the RPC API
port: 18332
}
}
},
]

Hope this helps!


#45

Great, thanks very much. I think I’m ready to test it out now just as soon as goTenna send me the SDK token. Will update…


#46

I have the server running (it gave me this output):

[20190303 19:57:24.631 040 MiB] Process ID: 6970
[20190303 19:57:25.164 041 MiB] Initialized storage memory-cache
[20190303 19:57:26.218 042 MiB] HTTP server listening on port 8091

But when I run txtenna.py, I get the following output :

Traceback (most recent call last):
File “txtenna.py”, line 10, in
import requests
ImportError: No module named requests

Any ideas?


#47

I should add to the Readme that you need to add some python module dependencies using pip. I’ve added them to a file called requirements.txt .

Just type the following to add the required python modules:

pip install -r requirements.txt

Or you can do them by hand by typing:

pip install requests

And the same for any other missing imports.


#48

Thanks for that. It seemed to work, but unfortunately now I get this message:

Traceback (most recent call last):
File “txtenna.py”, line 10, in
import requests
File “/home/user1/.local/lib/python2.7/site-packages/requests/init.py”, line 44, in
import chardet
ImportError: No module named chardet

I thought maybe it didn’t install for some reason so tried pip install chardet, but got this:

Requirement already satisfied: chardet in /usr/lib/python2.7/dist-packages (3.0.4)